Office 2010 Pro Plus + Win 7 Ult/Ent + SharePoint + Office XP Docs + Macros = Trouble

I'll get into this error later.

The picture is worth a thousand words.

If you have seen this column table repair on a DOC created in Office XP with basic Macros you know what I'm going to ask.

How and What did you change to force Office not to auto repair or auto break.

Word _2010_Issue _1 

Microsoft Word with embedded Macros. 
Simple macros, Form field spell check and protect and unprotect. 
The issue I am seeing is when you open a Word document from SharePoint using Windows XP and Office 2010. See the 55 second video. If you know the fix comment.
It appears that Windows 7 Ult/Ent attempt to repair the document as it is pulled from the SharePoint folder. Saving it locally doesn't work either. Could be header, footer, or something else. Simulated issue info below. I'll link later to a more detailed report.

Please do not say it's "Macro Settings in the Trust Center" I've tested the following systems. 
Windows XP - Office XP, Office 2003, Office 2007, Office 2010 Standard and Office 2010 Pro Plus on SharePoint, Only 2010 fails to open the document. 
Windows 7 Pro with any version of office (not tested on XP) works just fine. 
Windows 7 Ultimate fails to open when using Office 2010. 
Windows 7 Enterprise fails to open when using Office 2010. 
Windows 8 Pro with Office 2013 works fine.

 

If you have a fix for this and really can fix it get in touch (contact me). 

I'll publish it for you if you would like and I'll compensate you for your time.

That's if you don't have me spending hours testing what you think you know. You either know the fix or you are just experimenting with a fix.

I have 2 documents that break under the following setup: Office 2010 Pro or 2010 Pro Plus with Windows 7 Ultimate or Enterprise. The documents work with XP, Vista, Win 7 Pro and Win 8 Pro using Office XP, 2003, 2007, 2010, 2013. What can possibly make this type of error. It handles the document like it has a corrupted header.